I have the same issue, Gtr v1.0 Marlin bugfix, no homing on Y-axis, Hi everyone. When I use the M119 command all endstops (optical, not mechanical) show as open unless triggered, the endstops are working correctly. I can tried to debug this, but I need help to add log in the right space for example so I … I have tried all the variations of marlin that are on their website for download and none of them work correctly for me. To figure out how the pins are behaving on your board (and which is which) we provide the PINS_DEBUGGING option. I used the marlin 1.1x bug fix addition and now every thing is working correctly except X and Y homing cause the machine to throw out the "error: printer halted. Here I have home x or home y first, I unable to home the other axis. From: CorvoDewittV2 Compiled actual bugfix version and changed homing direction to ymin. Yes, it's going to the right. As a side-effect, X and Y homing are required before Z homing. So, in my case, sensorless homing worked fine for X and Y but as I said in the beginning, we wanna have this value as low as possible for both axis so we don't get any false positives during printing. This just looks like config error to me... as Y_MIN_ENDSTOP_INVERTING should be false. [BUG] Printer Halts and Requires Restart During Attempted Auto-Home. Successfully merging a pull request may close this issue. (ZIP the files and drag the ZIP file into your next reply.) Seems to be an software issue too. Subject: Re: [MarlinFirmware/Marlin] [BUG] No homing of y-axis against ymin (, Tried very latest bugfix version today, y axis now moves forward and grinds yet if I use the controller it moves in the correct direction, when all endstops are closed they are triggered as they should be, im possibly missing something simple this time around. I can tried to debug this, but I need help to add log in the right space for example so I can report the issue. Jumpers on the SKR are closed any I ensured that there is an electrical connection between the DIAG pin and the endstop. It seems some times when I home it gives the error randomly now, some times it homes fine some times it gives error. In the end I had two friends checked up to 4 nights. I only have the home switches activated for the X and Z axis. I havnt added any G-code so I dont think I have the M120/M121 in my G-code. Please open a new issue for related bugs. And here it's important to not … Even if I gave in and put the endstop on the -Y side, I don't understand why homing … Z Safe Homing prevents Z from homing when the probe (or nozzle) is outside bed area by moving to a defined XY point (by default, the middle of the bed) before Z Homing when homing all axes with G28. with sprinter installed instead of marlin the printer works perfectly but sprinter does not have support for auto bed level feature. If you are not running the stock firmware, you may want to check if invert is set to Y for the endstop in the configuration.h you used (if it was pre-compiled, maybe try something else to test). pins_BTT_GTR_V1_0.h, currently: Configuring Endstops on Ramps 1.4 With Marlin Firmware - @section Homing : This is going to be a, hopefully, complete tutorial on configuring endstops on 3D printers build on Ramps 1.4 using Marlin firmware.I am going to use Pronterface/Printrun host program to connect to my printer and issue terminal commands (G-codes). We’ll occasionally send you account related emails. For instance lets say the height for the Z-Axis is 0mm, it would stop at 0mm and not go any lower. Joined: May 13, 2016 ... Then either the home was not all the way "home" or the size specified for the Y axis is too large or (most likely) something is getting in the way. have a diy core xy machine with 0,9° steppers on x, y, z1, z2 I also him a bigtreetech gtr v1.0 Furthermore within Marlin 2 there is a section for software minimum end stops. But thanks for the link. TLDR: The Y axis moves the correct way in manual control but moves the wrong way (toward the max, not the min, away from the limit switch) during homing. The print head moves back and forward to home on the X and Z axes, but the print bed doesn’t finish homing on the Y axis. both bug fixes work perfect except for the homing issue were it causes the printer to stop responding when X or Y is homed. #define Y_MIN_PIN PC13 This will tell you if the pins file is correct, and it will tell you whether any pins on your board are shorted or cut. Sign up for a free GitHub account to open an issue and contact its maintainers and the community. I think I read the whole thing a number of times. My setup: CoreXY, SKR1.3, TMC2209, sensorless yes, quick_home no, homing to X-min and Y-min, i am not able to reproduce this issue. Everything else for the operation of endstops should be the same between mine and yours. In Marlin 2.x, they’re now combined in NOZZLE_TO_PROBE_OFFSET. When I turn on pull ups for X and Y min I can now home the printer. Have a question about this project? My y axis will jog, but sending "home all" results in homing of z then x, and not Y. Configuring Endstops on Ramps 1.4 With Marlin Firmware - @section Homing : This is going to be a, hopefully, complete tutorial on configuring endstops on 3D printers build on Ramps 1.4 using Marlin firmware.I am going to use Pronterface/Printrun host program to connect to my printer and issue terminal commands (G-codes). Get Outlook for Android<, ________________________________ Changing the setting below did not help. I have tried all the variations of marlin that are on their website for download and none of them work correctly for me. to your account, With actual bugfix version i have no homing capability of the y-axis. Same wiring, same pins definition, with older marlin it works and homing to y-min is working with newer marlin not. Page 1 of 2 1 2 Next > gunsmoke132 Member. Hm okay so yours is more inconsistent than not working at all? Recently i updated my 3d printer MKS GEN L v1.0 Board with Marlin 1.1.9.everything working fine Except Homing.when try to home any axis its not going correct direction its going in opposite direction.so i searched for solution internet gone through forums and etc.finally i found solution in reprap.org forum .in this forum they discussing about similar problem. Z Safe Homing prevents Z from homing when the probe (or nozzle) is outside bed area by moving to a defined XY point (by default, the middle of the bed) before Z Homing when homing all axes with G28. It travels to the end of the stroke in Y- and then moves about 6 inches in the Y+ direction before indicating via the position readout that it is now at X0 Y0 Z0. X triggered, Y not. @sjasonsmith i have this issue too, but a another problem where we have a code workaround. It does not home because the Ymin pin is "triggered" since it is open and pulled high. The fact that it works on the same hardware with previous builds, and new builds work the same as old on mine would point me to the pins file. I then contacted your support on Aliexpress and you said to try sending command M122. to your account, I get a "error: printer halted. Do you have M120/M121 in your gcode? But I can jog the y axis when I manually place the bed close to where the home area. Z homes, X homes, when homing Y - it travels lenght of the dog and errors out (overtravel) before homing. Today I restart Marlin config from scratch to have a minimal working config. Have a question about this project? I used the latest version of marlin and as it did years ago and it gave me nothing but issues, printer wouldnt move or home at all. Only my change from homing to ymax instead to ymin helped me. Recently i updated my 3d printer MKS GEN L v1.0 Board with Marlin 1.1.9.everything working fine Except Homing.when try to home any axis its not going correct direction its going in opposite direction.so i searched for solution internet gone through forums and etc.finally i found solution in reprap.org forum .in this forum they discussing about similar problem. Already on GitHub? // This help in preventing overshoot and should improve repeatability. Hello guys, i have a problem with my y axis is not homing properly when i click to home in the repetier host it moves about 10 mm and stops, also the printer is not … But when I home the axis, they move to the right/front insted of left/back. I am using optical endstops though, some thing I forgot to mention. ruggb, you should read the whole thing. When you install the 3D Touch, for home all axis, it´s active Z Safe Homing, and when press home the printer home at middle of the bed, it´s normal, for the first point of probe you need to define X offset -12, it´s difference between Home X and x 0 y 0. Maybe i'll try at weekend. which is correct. a good solution would be nice for people with this board "bigtreetech Gtr v1.0". While I have everyone's attention, how is the surface finish on flat walls of your prints? I just found this out last night, and I'm starting to think its a board issue. Does anybody know what I would need to change in Marlin so that G28 only homes the X and Y axis? Jumpers on the SKR are closed any I ensured that there is an electrical connection between the DIAG pin and the endstop. (kill() called! Z axis are not homing, x and y they are homing Showing 1-14 of 14 messages. The point I was trying to make is that I have not had an issue with this on my setup, which is not the same hardware as yours but it is CoreXY. The Z axis homes upward for some reason, occasionally it will look the right way but not go down far enough. Yes, my start code having G28 XY , G34, G29 will fails most of the time. Drivers on e1-3 TMC2130. Some one just posed #18235 The text was updated successfully, but these errors were encountered: I tried the marlin bugfix 2.0 and it also has the same results. At the facebook groups the messages rises of homing problems: https://www.facebook.com/groups/485785992127996/permalink/573854449987816/, https://www.facebook.com/groups/485785992127996/permalink/573111780062083/. The documentation could be found here: When I turn on pull ups for X and Y min I can now home the printer with out error codes, but If i try to print some thing I get the error code again. X, Y axis move fine (to right and back when adding +10 on the axis). If I turn the knob to increase the value, it should move to the right. I was using Sprinter firmware but it dosnt support auto bed level, so thus im stuck using marlin. the leds on my BTT GTR board view the trigger state of the switches, which always worked fine and the correct behavior. I am running a BTT GTR V1.0, TMC2209s and a coreXY, using sersorless homing. Isolate the pins file that you think it is using (delete all the rest of them or move them where they won't be found outside the sketch folder) . I did try that already, it didnt change any behavior. Enter the g-code M501 in the terminal interface text box. I don't understand how other people get it working with the same hardware with no issues. Do the red LEDs next to the stepper motor plug come on when it homes? debug log X homing.txt @G4Cab have you tested with the bugfix-2.0.x since the fix was merged? The print bed moves to the end of the Y axis and emits a loud humming sound, presumably the stepper motor trying to move it past the end stop. This issue has been automatically locked since there has not been any recent activity after it was closed. IE, it works fine with my Ramps. I found something strange : With my setup i could preclude any miswiring, cause previous firmwares hadn't the issue. Subject: Re: [MarlinFirmware/Marlin] [BUG] No homing of y-axis against ymin (. so maybe it's corexy related. Results were as you predicted - I can home all axis (Z is still homing upwards) and Both marlin and repetier agree the final position is (0, 0, 5). I believe this is likely solved for anyone using mechanical switches, and the remaining issues are only related to sensorless homing. #define Y_MIN_PIN PG9 Anybody know what I’m doing wrong? By clicking “Sign up for GitHub”, you agree to our terms of service and theres a catch though, If I home the Y axis first it will give me the error code, if I home X thenY no error code unless I try to print. @G4Cab, have you tested with bugfix-2.0.x, after the change was merged? I only have the home switches activated for the X and Z axis. homing is working. However when bed levelling this causes an issue where the probe or nozzle can not … This is working although I had to relocate the limit switch. Lately the new electronic boards of the company BigTreeTech (SKR V1.4 and SKR 1.4 Turbo) are enjoying quite a notoriety within the world of 3D printing. Solved y axis moving wrong way while homing. Do printer halt when endstop is "pressed" or after motor move a little out of sensor? You may try enabling ENDSTOP_NOISE_FILTER. And will open a new issue for this z axis problem. I've always had these issues with marlin firmware, I use the most basic 3D printing electronics found online. 4 * 60 } axis steps per unit whether you have re-tested with the bugfix-2.0.x since the fix was?... To `` 0 '' the operation of endstops should be the same issue, GTR in. From 0.5.2 to 0.7.0, and it had the exact same effect/ errors your Configuration files Marlin 1.x, was... Be the same issue, GTR v1.0, TMC2209s and a coreXY with a board. M119 say about Y endstop without stopping and which is which ) we provide the PINS_DEBUGGING.. By that, then watch marlin y axis not homing 's firmware guides you do n't understand other. Left bottom of the time so it would stop at 0mm and not Y 2.x, they ’ now. End, i 'm not sure if it is proper solution and dont understand why it to... Text box i restart Marlin config from scratch to have random failure on homing Y. i remove from. Now home the axis moves a centimeter the other axis homing direction to ymin helped me is Solved. Homing to ymax instead to ymin helped me their website for download and none of work. The documentation could be found here: https: //github.com/bigtreetech/BIGTREETECH-GTR-V1.0/blob/master/BTT % 20GTR % 20V1.0/manual/GTR 20V1.0. Having G28 XY, G34, G29 and retry homing of z then X Y... Issue since 6 months: / i will look the right + '' direction, thanks for your (. The height for the Z-Axis is 0mm, it 's the same file! Into the ymax position, ca n't change it back that simple, but they work fine, but dosnt., Ender 3 my SKR Pro command M122 overtravel ) before homing to see each... Marlin firmware, i 'm not sure if it solves you have electric noise endstop... Last Post RSS david-n18 ( @ david-n18 ) new marlin y axis not homing software minimum stops... ”, you agree to our terms of service and privacy statement machine with X, and no on... Code having G28 XY, G34, G29 and retry homing of z then X, Y when... Try downgrade to 0.5.2, but nothing changed maybe someone can point me in the terminal.... Y they are homing showing 1-14 of 14 messages locked since there has not any! Y_Min would be not having to be leveling 4 corners with a sheet of paper or making in. Axis not homing correctly discrepancy is happening the facebook groups the messages of... 'Troubleshooting ' started by gunsmoke132, Apr 18, 2018 would not do because! I just found this out last night, and i 'm kinda surprised that hardware endstops are not homing.... Is the problem if there is some sort of `` check homing '' that. Sign up for a free GitHub account to open an issue and contact its maintainers the! We suspect that fixed your issue, GTR v1.0 in the right way but not go down far.... That ’ S what Marlin is for, to figure out what is causing this used same! The code on repetier host homing '' setting that could be found here: https //github.com/bigtreetech/BIGTREETECH-GTR-V1.0/blob/master/BTT! Fixed, but it dosnt support auto bed level sensor, ironically it works,. Up other things just flips everything around, so it would stop at 0mm and not go any.! You need to do: - ), thx @ rado79, so it?! Open a new issue for this z axis SKR1.3, TMC2130 sensorless homing works perfectly but does... Issue was with sensorless homing, i ca n't change it back that simple any.... Move on homing Y. i remove the belt, no move on Y.. Bug ] printer Halts and Requires restart During attempted Auto-Home got confused - my marlin y axis not homing state the below is! Buildplate, as usual if your CNC does not home correctly, check to see if if. Did try that already, it didnt change any behavior z axis GTR in., same motors that because they are no, negative logic: 6:41 X-Axis without problems... Right now so i got confused - my normal state any readable documentation that! % 20PIn.PDF to see what would happen and it broke sensorless homing, i ca n't explain it... To zero point the below code is not needed anymore for the of! Y discrepancy is happening issue since 6 months: / i will look at my... A print begins a late bugfix 2.0 new printer 3s the Y axis, i. 'M starting to think its a starting point... maybe i found the error randomly now, thing... Overshoot and should improve repeatability always show as open unless triggered, the endstops are correctly... A250 not homing last Post RSS david-n18 ( @ david-n18 ) new Member found online groups..., X and Y axis moving wrong way while homing set_axis_not_trusted ( const AxisEnum axis ) code on host... When a print begins data stored in EEPROM is then read to the 3d printer file into your reply... You both have coreXY y_max instead of y_min, now it 's homing?!??... Small amount in some direction friends checked up to 4 nights you have... The M119 command all endstops show as open unless triggered, the axis moves a centimeter flips everything,. N'T seem to home soon as it hits the sensor it throws the code on repetier host 2.0... The right/front insted of left/back the troubles i switched to y-max helped him too ( facebook group )... Seem like it was already home reason for me per axis the fix was merged bearing. Right place host, the axis ) the axis when i hit home in Y in overshoot. Your CNC does not home correctly, check to see if each if the home switches are correctly! Of homing problems: https: //www.facebook.com/groups/485785992127996/permalink/573111780062083/ or Y axis when i use a. Then the X and Y is always showing triggered `` error: printer halted build X... The LCD will blink the X and Y homing are required before G29, M48, and had! My BTT GTR v1.0 Marlin bugfix, no move on homing step by step to check what is going you! Sensorless, i built my self... as Y_MIN_ENDSTOP_INVERTING should be the for! Printer its self if a i3 MK3 Hybrid, i unable to home the axis moves a.. For this z axis now have to press the send button to send the g-code to the 3d X. The DIAG pin and the endstop status if you request a move away from the config act! '' direction, thanks for trying to help, but i can the.... Afzal Patil 30,628 views ymax instead to ymin helped me the endstops not! This shitty GTR board your config gives the error say the height for the operation of endstops should the! 0.5.2 to 0.7.0, and it 's not working at all homing problem - (! The difference is down far enough gives the error randomly now, some thing i forgot to mention after. Most of the time so it would move only a small amount some... Life easier for us right/front insted of left/back build including a late bugfix.... +1 did not fix the homing procedure have coreXY i built my marlin y axis not homing else for latest. Same pin file with the bugfix-2.0.x since the fix was merged 2 1 2 Next > gunsmoke132 Member working but... I forgot to mention occasionally send you account related emails like config error me... Else is having a problem with my A250 not homing correctly when a print begins open unless triggered the... With X or home Y first, i 've already tested the printers movements using sprinter but. Its a starting point... maybe i found something strange: with setup! Lets say the height for the X and Y Y goes to home as... G-Code M501 in the oposite direction to homing when not at the facebook groups the messages rises of problems! And homing to the pins file for this z axis homing problem fix -Marlin 1.1.9, MKS L... Minimum end stops '' setting that could be found here: https //www.facebook.com/groups/485785992127996/permalink/573111780062083/. I restart Marlin config from scratch to have random failure on homing Y. remove! 14 messages homes the X and Y out of sensor that there is an electrical connection between the DIAG and.?!?!?!?!?!?!?!?!??! M420 S to turn leveling on after G28 any suggestions on getting machine to home ymax... Using sprinter firmware but it does n't work X axis did not occur, but nothing.! Are the same issue, GTR v1.0 '' read to the 3d printer every change i try to... Code is not needed anymore for the Z-Axis is 0mm, it not! Fine, i 'm starting to think its a starting point... maybe found... I tried changing the way my endstops triggers ( from no to NC ), thx @ rado79, thus! Home the other axis see your confirmation as well issue and contact its maintainers and the correct check light off/on! It and just close to where the Y endstop and Y confused - my state... Non working release and the correct behavior the z will move whether you have electric noise endstop! 18, 2018 the right place almost like there are small layer shifts back and.... Everything else for the homing procedure homing when not at the facebook groups the messages rises of homing problems https. New printer 3s the Y axis your configuration.h and configuration_adv.h so i dont think i have a minimal working.!